Improper Validation of Array Index Affecting kafka-3.8 package, versions <3.8.1-r67


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.41% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-KAFKA38-21782754
  • published29 Oct 2026
  • disclosed26 Oct 2026

Introduced: 26 Oct 2026

NewCVE-2026-116590  (opens in a new tab)
CWE-129  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Chainguard kafka-3.8 to version 3.8.1-r67 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kafka-3.8 package and not the kafka-3.8 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

snappy-java is a Java port of the snappy, a fast C++ compresser/decompresser developed by Google. Prior to 1.1.10.9, Snappy.arrayCopy(Object src, int offset, int byteLength, Object dest, int destOffset) passes caller-supplied ranges to native memcpy without validating either array, allowing negative or oversized byteLength and offset values to read or write outside array bounds and crash the JVM. SnappyOutputStream.rawWrite and SnappyInputStream.rawRead, including their typed-array write and read methods, pass caller-controlled ranges through this primitive, and typed-array byte-size calculations can overflow int. This issue is fixed in version 1.1.10.9.

CVSS Base Scores

version 3.1