CVE-2026-56859 Affecting karpenter-fips-1.10 package, versions <1.10.2-r2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.57% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-KARPENTERFIPS110-18848786
  • published16 Aug 2026
  • disclosed13 Aug 2026

Introduced: 13 Aug 2026

CVE-2026-56859  (opens in a new tab)

How to fix?

Upgrade Chainguard karpenter-fips-1.10 to version 1.10.2-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream karpenter-fips-1.10 package and not the karpenter-fips-1.10 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Previously, DecodeElement would reset the depth counter causing it to never fire; this could lead to stack exhaustion.

CVSS Base Scores

version 3.1