CVE-2025-37732 Affecting kibana-8.17 package, versions <8.17.10-r11


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.18% (8th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-KIBANA817-15130995
  • published28 Jan 2026
  • disclosed15 Dec 2025

Introduced: 15 Dec 2025

CVE-2025-37732  (opens in a new tab)

How to fix?

Upgrade Chainguard kibana-8.17 to version 8.17.10-r11 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kibana-8.17 package and not the kibana-8.17 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Improper neutralization of input during web page generation ('Cross-site Scripting') (CWE-79) allows an authenticated user to render HTML tags within a user’s browser via the integration package upload functionality. This issue is related to ESA-2025-17 (CVE-2025-25018) bypassing that fix to achieve HTML injection.