Integer Overflow or Wraparound Affecting kots package, versions <1.130.9-r3


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.5% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-KOTS-21830519
  • published30 Oct 2026
  • disclosed29 Sept 2026

Introduced: 29 Sep 2026

NewCVE-2026-63209  (opens in a new tab)
CWE-190  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Chainguard kots to version 1.130.9-r3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kots package and not the kots package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

compress provides various compression algorithms. Prior to version 1.18.7, a signed integer overflow vulnerability in s2.NewDict() allows an attacker to bypass repeat index validation by supplying a dictionary with a uvarint-encoded repeat value exceeding MaxInt64. When Dict.Encode() is subsequently called, the overflowed negative repeat value causes an out-of-bounds memory access via unsafe.Pointer arithmetic, crashing the process with SIGSEGV. This issue has been patched in version 1.18.7.

CVSS Base Scores

version 3.1