Improper Certificate Validation Affecting kubeflow-centraldashboard package, versions <2.0.0-r8


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.25% (16th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-KUBEFLOWCENTRALDASHBOARD-22107284
  • published1 Nov 2026
  • disclosed29 Oct 2026

Introduced: 29 Oct 2026

NewCVE-2026-119190  (opens in a new tab)
CWE-295  (opens in a new tab)
CWE-436  (opens in a new tab)

How to fix?

Upgrade Chainguard kubeflow-centraldashboard to version 2.0.0-r8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kubeflow-centraldashboard package and not the kubeflow-centraldashboard package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior to 1.4.1, node-forge parsed deprecated extension OIDs 2.5.29.10 and 2.5.29.13 as basicConstraints, and pki.verifyCertificateChain() used the first extension with that name. Exploitation requires a CA trusted by the application to issue a certificate carrying an attacker-supplied deprecated-OID extension, commonly because the CA copies extensions from a certificate signing request. By placing a permissive deprecated extension before the genuine 2.5.29.19 basicConstraints extension, the certificate holder could have the certificate accepted as a CA and issue certificates for arbitrary names, enabling server or client impersonation. If the issuing CA adds a keyUsage extension without keyCertSign, node-forge rejects the chain. This issue is fixed in version 1.4.1.