CVE-2024-36623 Affecting kubevirt-cdi-uploadserver-1.5 package, versions <1.59.2-r5


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.64% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-KUBEVIRTCDIUPLOADSERVER15-17679919
  • published30 Jun 2026
  • disclosed29 Nov 2024

Introduced: 29 Nov 2024

CVE-2024-36623  (opens in a new tab)

How to fix?

Upgrade Chainguard kubevirt-cdi-uploadserver-1.5 to version 1.59.2-r5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kubevirt-cdi-uploadserver-1.5 package and not the kubevirt-cdi-uploadserver-1.5 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

moby through v25.0.3 has a Race Condition vulnerability in the streamformatter package which can be used to trigger multiple concurrent write operations resulting in data corruption or application crashes.