Arbitrary Code Injection Affecting langfuse-4 package, versions <4.68.0-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.34% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-LANGFUSE4-21493271
  • published23 Oct 2026
  • disclosed20 Oct 2026

Introduced: 20 Oct 2026

NewCVE-2026-112949  (opens in a new tab)
CWE-94  (opens in a new tab)
CWE-116  (opens in a new tab)
CWE-306  (opens in a new tab)

How to fix?

Upgrade Chainguard langfuse-4 to version 4.68.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream langfuse-4 package and not the langfuse-4 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Vitest is a Vite-native testing framework for JavaScript and TypeScript projects. From 2.1.0-beta.7 until 4.1.12 and 5.0.3, an unauthenticated non-browser WebSocket client that can reach a development server using interceptorPlugin can register a manual mock whose attacker-controlled url createManualModuleSource inserts unescaped into generated module source. When the developer browser loads the affected module, attacker-controlled JavaScript executes on the development-server origin. This issue is fixed in versions 4.1.12 and 5.0.3.

CVSS Base Scores

version 3.1