Protection Mechanism Failure Affecting langfuse-4 package, versions <4.68.0-r2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.51% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-LANGFUSE4-21692422
  • published24 Oct 2026
  • disclosed21 Oct 2026

Introduced: 21 Oct 2026

NewCVE-2026-114139  (opens in a new tab)
CWE-693  (opens in a new tab)

How to fix?

Upgrade Chainguard langfuse-4 to version 4.68.0-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream langfuse-4 package and not the langfuse-4 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Sentry-Javascript is an official Sentry SDKs for JavaScript. From 9.36.0 until 9.47.2, 10.75.2, and 11.0.0-rc.1, the webpack integration for @sentry/nextjs skips application middleware for every request path under a configured tunnelRoute, while the tunnel rewrite serves only the exact tunnel path with valid o and p query parameters. When an application route directly collides with the tunnel path or a root dynamic segment resolves under it, an unauthenticated request can reach that route without middleware authorization. Exploitation requires tunnelRoute, a webpack build, a colliding route, and middleware being the only authorization control. This issue is fixed in versions 9.47.2, 10.75.2, and 11.0.0-rc.1.