Arbitrary Code Injection Affecting langfuse-fips-4 package, versions <4.68.0-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.39% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-LANGFUSEFIPS4-21493463
  • published23 Oct 2026
  • disclosed21 Oct 2026

Introduced: 21 Oct 2026

NewCVE-2026-114125  (opens in a new tab)
CWE-94  (opens in a new tab)
CWE-346  (opens in a new tab)
CWE-1021  (opens in a new tab)

How to fix?

Upgrade Chainguard langfuse-fips-4 to version 4.68.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream langfuse-fips-4 package and not the langfuse-fips-4 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Storybook is a frontend workshop for building user interface components and pages in isolation. From 8.0.0 until 8.6.19, 9.1.21, 10.6.2, and 11.0.0-alpha.6, a malicious website can interact with the preview of a running Storybook development server. Insufficient iframe embedding and message-origin restrictions can allow attacker-controlled events to reach the running preview. A developer must visit the malicious website and interact with the injected interface. The attack can cause unauthorized changes to story files and, if a changed file is later executed by a local runtime, arbitrary code execution with the developer's privileges. This issue is fixed in 8.6.19, 9.1.21, 10.6.2, and 11.0.0-alpha.6.

CVSS Base Scores

version 3.1