Uncontrolled Recursion Affecting librechat package, versions <0.8.8-r4


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.48% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-LIBRECHAT-21434223
  • published23 Oct 2026
  • disclosed20 Oct 2026

Introduced: 20 Oct 2026

NewCVE-2026-113650  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

Upgrade Chainguard librechat to version 0.8.8-r4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream librechat package and not the librechat package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

ApostropheCMS is an open-source Node.js content management system. In sanitize-html 2.18.0, when an <iframe> is not allowed and disallowedTagsMode is 'discard' (the defaults), its raw-text content is re-sanitized by a recursive call to sanitizeHtml(text, options). The recursion has no bound and starts each nested call with a fresh state. This vulnerability is fixed in 2.18.1.

CVSS Base Scores

version 3.1