Integer Overflow or Wraparound Affecting loki-3.7 package, versions <3.7.7-r4


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.57% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-LOKI37-21830683
  • published30 Oct 2026
  • disclosed29 Sept 2026

Introduced: 29 Sep 2026

CVE-2026-63209  (opens in a new tab)
CWE-190  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Chainguard loki-3.7 to version 3.7.7-r4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream loki-3.7 package and not the loki-3.7 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

compress provides various compression algorithms. Prior to version 1.18.7, a signed integer overflow vulnerability in s2.NewDict() allows an attacker to bypass repeat index validation by supplying a dictionary with a uvarint-encoded repeat value exceeding MaxInt64. When Dict.Encode() is subsequently called, the overflowed negative repeat value causes an out-of-bounds memory access via unsafe.Pointer arithmetic, crashing the process with SIGSEGV. This issue has been patched in version 1.18.7.

CVSS Base Scores

version 3.1