Improper Certificate Validation Affecting mapotf-fips package, versions <0.0.0_git20260426-r5


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.5% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-MAPOTFFIPS-16965123
  • published28 May 2026
  • disclosed22 May 2026

Introduced: 22 May 2026

CVE-2026-39835  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Chainguard mapotf-fips to version 0.0.0_git20260426-r5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapotf-fips package and not the mapotf-fips package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

SSH servers which use CertChecker as a public key callback without setting IsUserAuthority or IsHostAuthority could be caused to panic by a client presenting a certificate. CertChecker now returns an error instead of panicking when these callbacks are nil.

References

CVSS Base Scores

version 3.1