CVE-2025-51471 Affecting mods package, versions <1.8.1-r12


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
18.53% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-MODS-16643030
  • published13 May 2026
  • disclosed22 Jul 2025

Introduced: 22 Jul 2025

CVE-2025-51471  (opens in a new tab)

How to fix?

Upgrade Chainguard mods to version 1.8.1-r12 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mods package and not the mods package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Cross-Domain Token Exposure in server.auth.getAuthorizationToken in Ollama 0.6.7 allows remote attackers to steal authentication tokens and bypass access controls via a malicious realm value in a WWW-Authenticate header returned by the /api/pull endpoint.