CVE-2026-56852 Affecting mods package, versions <1.8.1-r17


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.48% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-MODS-18310074
  • published26 Jul 2026
  • disclosed21 Jul 2026

Introduced: 21 Jul 2026

CVE-2026-56852  (opens in a new tab)

How to fix?

Upgrade Chainguard mods to version 1.8.1-r17 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mods package and not the mods package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A norm.Iter can enter an infinite loop when handling input containing invalid UTF-8 bytes.

CVSS Base Scores

version 3.1