CVE-2025-22871 Affecting mongodb-k8s-operator-version-upgrade-post-start-hook-fips package, versions <0.12.0-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.83% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-MONGODBK8SOPERATORVERSIONUPGRADEPOSTSTARTHOOKFIPS-19438038
  • published1 Sept 2026
  • disclosed8 Apr 2025

Introduced: 8 Apr 2025

CVE-2025-22871  (opens in a new tab)

How to fix?

Upgrade Chainguard mongodb-k8s-operator-version-upgrade-post-start-hook-fips to version 0.12.0-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mongodb-k8s-operator-version-upgrade-post-start-hook-fips package and not the mongodb-k8s-operator-version-upgrade-post-start-hook-fips package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

The net/http package improperly accepts a bare LF as a line terminator in chunked data chunk-size lines. This can permit request smuggling if a net/http server is used in conjunction with a server that incorrectly accepts a bare LF as part of a chunk-ext.

CVSS Base Scores

version 3.1