CVE-2025-24970 Affecting neo4j-5.26 package, versions <5.26.4-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
2.19% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-NEO4J526-9408198
  • published15 Mar 2025
  • disclosed10 Feb 2025

Introduced: 10 Feb 2025

CVE-2025-24970  (opens in a new tab)

How to fix?

Upgrade Chainguard neo4j-5.26 to version 5.26.4-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream neo4j-5.26 package and not the neo4j-5.26 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Netty, an asynchronous, event-driven network application framework, has a vulnerability starting in version 4.1.91.Final and prior to version 4.1.118.Final. When a special crafted packet is received via SslHandler it doesn't correctly handle validation of such a packet in all cases which can lead to a native crash. Version 4.1.118.Final contains a patch. As workaround its possible to either disable the usage of the native SSLEngine or change the code manually.

CVSS Base Scores

version 3.1