CVE-2026-106071 Affecting nodejs-26 package, versions <26.12.1-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-NODEJS26-21723695
  • published27 Oct 2026
  • disclosed23 Oct 2026

Introduced: 23 Oct 2026

NewCVE-2026-106071  (opens in a new tab)

How to fix?

Upgrade Chainguard nodejs-26 to version 26.12.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nodejs-26 package and not the nodejs-26 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A flaw in Node.js Permission Model filesystem enforcement can grant access to paths that do not match a wildcard --allow-fs-read or --allow-fs-write rule.

When the requested path is shorter than the prefix of a wildcard grant, the radix tree lookup stops comparing early and treats the path as a match. For example, --allow-fs-read=/etc/passwd.* also allows reading /etc/passwd. This requires the wildcard grant to sit directly under the root of the permission tree, for example when it is the only grant for that scope. This is a different root cause from CVE-2026-58043.

This vulnerability affects Node.js 26.x.

CVSS Base Scores

version 3.1