CVE-2026-56858 Affecting nvidia-nsight-compute-12.9 package, versions <2025.2.1.3-r8


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-NVIDIANSIGHTCOMPUTE129-21708778
  • published25 Oct 2026
  • disclosed13 Aug 2026

Introduced: 13 Aug 2026

CVE-2026-56858  (opens in a new tab)

How to fix?

Upgrade Chainguard nvidia-nsight-compute-12.9 to version 2025.2.1.3-r8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvidia-nsight-compute-12.9 package and not the nvidia-nsight-compute-12.9 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Previously, pathological inputs could close an unescaped '/' early, allowing for attack-controlled data to inject arbitrary content, potentially leading to XSS.

CVSS Base Scores

version 3.1