Insufficiently Protected Credentials Affecting nvidia-nsight-compute-13.3 package, versions <2026.2.1.5-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.98% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-NVIDIANSIGHTCOMPUTE133-18280214
  • published24 Jul 2026
  • disclosed9 Jun 2025

Introduced: 9 Jun 2025

CVE-2024-47081  (opens in a new tab)
CWE-522  (opens in a new tab)

How to fix?

Upgrade Chainguard nvidia-nsight-compute-13.3 to version 2026.2.1.5-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvidia-nsight-compute-13.3 package and not the nvidia-nsight-compute-13.3 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Requests is a HTTP library. Due to a URL parsing issue, Requests releases prior to 2.32.4 may leak .netrc credentials to third parties for specific maliciously-crafted URLs. Users should upgrade to version 2.32.4 to receive a fix. For older versions of Requests, use of the .netrc file can be disabled with trust_env=False on one's Requests Session.

CVSS Base Scores

version 3.1