Incomplete Blacklist Affecting pghero package, versions <3.8.0-r4


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.39% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PGHERO-18760708
  • published14 Aug 2026
  • disclosed12 Aug 2026

Introduced: 12 Aug 2026

CVE-2026-73491  (opens in a new tab)
CWE-184  (opens in a new tab)

How to fix?

Upgrade Chainguard pghero to version 3.8.0-r4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pghero package and not the pghero package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. From 2.25.0 until 2.25.2, Loofah::HTML5::Scrub.allowed_uri? does not reject javascript: URIs whose scheme is split or prefixed with the HTML5 named whitespace character references &Tab; or &NewLine;. CGI.unescapeHTML leaves those references intact, so allowed_uri? reports the URL safe even though a browser decodes and strips the tab or line feed and executes the resulting javascript: URL. This issue affects only callers that pass HTML-encoded strings directly to allowed_uri?; Loofah's default sanitize() path is not affected. This issue is fixed in version 2.25.2.

CVSS Base Scores

version 3.1