CVE-2024-36623 Affecting prometheus-2.51 package, versions <2.51.2-r48


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.64% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PROMETHEUS251-15993215
  • published12 Apr 2026
  • disclosed29 Nov 2024

Introduced: 29 Nov 2024

CVE-2024-36623  (opens in a new tab)

How to fix?

Upgrade Chainguard prometheus-2.51 to version 2.51.2-r48 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream prometheus-2.51 package and not the prometheus-2.51 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

moby through v25.0.3 has a Race Condition vulnerability in the streamformatter package which can be used to trigger multiple concurrent write operations resulting in data corruption or application crashes.