CVE-2024-36620 Affecting promxy-fips package, versions <0.0.93-r4


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.82% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PROMXYFIPS-14889325
  • published7 Jan 2026
  • disclosed29 Nov 2024

Introduced: 29 Nov 2024

CVE-2024-36620  (opens in a new tab)

How to fix?

Upgrade Chainguard promxy-fips to version 0.0.93-r4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream promxy-fips package and not the promxy-fips package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

moby v25.0.0 - v26.0.2 is vulnerable to NULL Pointer Dereference via daemon/images/image_history.go.