Inefficient Regular Expression Complexity Affecting py3.10-vllm-cuda-11.8 package, versions <0.9.0-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.54% (46th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PY310VLLMCUDA118-14889373
  • published7 Jan 2026
  • disclosed30 May 2025

Introduced: 30 May 2025

CVE-2025-48887  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade Chainguard py3.10-vllm-cuda-11.8 to version 0.9.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream py3.10-vllm-cuda-11.8 package and not the py3.10-vllm-cuda-11.8 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

vLLM, an inference and serving engine for large language models (LLMs), has a Regular Expression Denial of Service (ReDoS) vulnerability in the file vllm/entrypoints/openai/tool_parsers/pythonic_tool_parser.py of versions 0.6.4 up to but excluding 0.9.0. The root cause is the use of a highly complex and nested regular expression for tool call detection, which can be exploited by an attacker to cause severe performance degradation or make the service unavailable. The pattern contains multiple nested quantifiers, optional groups, and inner repetitions which make it vulnerable to catastrophic backtracking. Version 0.9.0 contains a patch for the issue.