Uncaught Exception Affecting py3.10-vllm-cuda-11.8 package, versions <0.9.0-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.58% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-PY310VLLMCUDA118-14889382
  • published7 Jan 2026
  • disclosed30 May 2025

Introduced: 30 May 2025

CVE-2025-48942  (opens in a new tab)
CWE-248  (opens in a new tab)

How to fix?

Upgrade Chainguard py3.10-vllm-cuda-11.8 to version 0.9.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream py3.10-vllm-cuda-11.8 package and not the py3.10-vllm-cuda-11.8 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the /v1/completions API with a invalid json_schema as a Guided Param kills the vllm server. This vulnerability is similar GHSA-9hcf-v7m4-6m2j/CVE-2025-48943, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.