CVE-2025-61732 Affecting quic-go-fips package, versions <0.59.0-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.53% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-QUICGOFIPS-15306394
  • published18 Feb 2026
  • disclosed5 Feb 2026

Introduced: 5 Feb 2026

CVE-2025-61732  (opens in a new tab)

How to fix?

Upgrade Chainguard quic-go-fips to version 0.59.0-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quic-go-fips package and not the quic-go-fips package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

A discrepancy between how Go and C/C++ comments were parsed allowed for code smuggling into the resulting cgo binary.

References

CVSS Base Scores

version 3.1