CVE-2024-36623 Affecting rke2-runtime-1.37 package, versions <1.37.0.2.1-r2


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.64% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-RKE2RUNTIME137-19956568
  • published19 Sept 2026
  • disclosed29 Nov 2024

Introduced: 29 Nov 2024

CVE-2024-36623  (opens in a new tab)

How to fix?

Upgrade Chainguard rke2-runtime-1.37 to version 1.37.0.2.1-r2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rke2-runtime-1.37 package and not the rke2-runtime-1.37 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

moby through v25.0.3 has a Race Condition vulnerability in the streamformatter package which can be used to trigger multiple concurrent write operations resulting in data corruption or application crashes.