Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') Affecting solr-9 package, versions <9.11.0-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-SOLR9-20694448
  • published9 Oct 2026
  • disclosed2 Jun 2026

Introduced: 2 Jun 2026

CVE-2026-46718  (opens in a new tab)
CWE-470  (opens in a new tab)

How to fix?

Upgrade Chainguard solr-9 to version 9.11.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream solr-9 package and not the solr-9 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite.

This issue affects Apache Calcite: from 1.5.0 before 1.42.

Users are recommended to upgrade to version 1.42, which fixes the issue.