Improper Input Validation Affecting tritonserver-backend-vllm-cuda-13.0 package, versions <25.11-r17


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.33% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-TRITONSERVERBACKENDVLLMCUDA130-21277822
  • published20 Oct 2026
  • disclosed5 Oct 2026

Introduced: 5 Oct 2026

NewCVE-2026-105756  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-248  (opens in a new tab)

How to fix?

Upgrade Chainguard tritonserver-backend-vllm-cuda-13.0 to version 25.11-r17 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tritonserver-backend-vllm-cuda-13.0 package and not the tritonserver-backend-vllm-cuda-13.0 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

vLLM is an inference and serving engine for large language models. Prior to 0.30.0, OpenAI-compatible request models accept a non-empty cache_salt value without enforcing the character and length restrictions required by the IPCCacheServerKey consumer in LMCache-MP. On deployments using the LMCache-MP connector, a salt that contains a forbidden character or exceeds the permitted length can raise an uncaught ValueError during scheduler cache lookup, causing EngineCore to terminate and denying service to all concurrent users. This issue is fixed in version 0.30.0.