Cross-site Scripting (XSS) Affecting unleash package, versions <8.2.1-r1


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.35% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-UNLEASH-21693986
  • published24 Oct 2026
  • disclosed20 Oct 2026

Introduced: 20 Oct 2026

NewCVE-2026-113654  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Chainguard unleash to version 8.2.1-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unleash package and not the unleash package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

ApostropheCMS is an open-source Node.js content management system, and sanitize-html provides a simple HTML sanitizer with a clear API. Prior to sanitize-html 2.18.0, a non-default nonTextTags configuration that includes noscript can end its discard region early when htmlparser2 emits an implied ancestor close inside noscript. Because scripting-enabled browsers treat noscript content as raw text while the parser does not model that mode, content intended to remain inert can survive sanitization and render; the issue does not generalize to every default nonTextTags element. This issue is fixed in sanitize-html 2.18.0.

CVSS Base Scores

version 3.1