CVE-2024-33394 Affecting virt-launcher-1.8 package, versions <1.8.4-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.33% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-VIRTLAUNCHER18-17803284
  • published3 Jul 2026
  • disclosed2 May 2024

Introduced: 2 May 2024

CVE-2024-33394  (opens in a new tab)

How to fix?

Upgrade Chainguard virt-launcher-1.8 to version 1.8.4-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream virt-launcher-1.8 package and not the virt-launcher-1.8 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

An issue in kubevirt kubevirt v1.2.0 and before allows a local attacker to execute arbitrary code via a crafted command to get the token component.

CVSS Base Scores

version 3.1