Improper Input Validation Affecting vllm-cuda-13.2 package, versions <0.32.0-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.27% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-VLLMCUDA132-21277829
  • published20 Oct 2026
  • disclosed5 Oct 2026

Introduced: 5 Oct 2026

NewCVE-2026-105754  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-617  (opens in a new tab)
CWE-639  (opens in a new tab)
CWE-668  (opens in a new tab)
CWE-704  (opens in a new tab)
CWE-1284  (opens in a new tab)

How to fix?

Upgrade Chainguard vllm-cuda-13.2 to version 0.32.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vllm-cuda-13.2 package and not the vllm-cuda-13.2 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

vLLM is an inference and serving engine for large language models. Prior to 0.30.0, the /inference/v1/generate endpoint in the disaggregated scale-out path accepts caller-supplied tensors in the features.kwargs_data field, cache identifiers in the features.mm_hashes field, ranges in the features.mm_placeholders field, and wire-selected multimodal field processors without rebinding them to the active model renderer contract. Forged grid geometry, field types, or non-positive placeholder lengths can terminate the shared EngineCore; when an attacker knows or can induce a victim's content hash, forged cache hashes can poison or retrieve cross-request encoder-cache state; and dropped sparse placeholder masks can alter replayed transport semantics. This issue is fixed in version 0.30.0.