Resource Exhaustion Affecting vllm-cuda-13.2 package, versions <0.32.0-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.3% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-VLLMCUDA132-21277838
  • published20 Oct 2026
  • disclosed5 Oct 2026

Introduced: 5 Oct 2026

NewCVE-2026-105760  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Chainguard vllm-cuda-13.2 to version 0.32.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vllm-cuda-13.2 package and not the vllm-cuda-13.2 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

vLLM is an inference and serving engine for large language models. Prior to 0.30.0, a caller can use the request-level media_io_kwargs field to select the GLMGA video backend and supply large values for the fps and max_frames options without a strict work ceiling. GLMGA constructs and deduplicates an attacker-sized pre-decode frame-index list, allowing a compact request and tiny valid video to consume disproportionate CPU time and memory in the shared media-loading executor. This issue is fixed in version 0.30.0.