Authorization Bypass Through User-Controlled Key Affecting vllm-openai-cuda-13.0 package, versions <0.31.0-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.2% (10th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-VLLMOPENAICUDA130-21175632
  • published17 Oct 2026
  • disclosed5 Oct 2026

Introduced: 5 Oct 2026

NewCVE-2026-105755  (opens in a new tab)
CWE-639  (opens in a new tab)

How to fix?

Upgrade Chainguard vllm-openai-cuda-13.0 to version 0.31.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vllm-openai-cuda-13.0 package and not the vllm-openai-cuda-13.0 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

vLLM is an inference and serving engine for large language models. Prior to 0.30.0, flash late-interaction scoring at the /score and /rerank endpoints derives each worker's query_key value from the caller-controlled X-Request-Id header. A concurrent request that reuses a victim's identifier can overwrite the cached query embedding so the victim's documents are scored against the attacker's query, and shared use counters can also cause a late-interaction cache-miss error. This issue is fixed in version 0.30.0.