Improper Input Validation Affecting vllm-openai-cuda-13.0 package, versions <0.31.0-r0


Severity

Recommended
low

Based on default assessment until relevant scores are available.

Threat Intelligence

EPSS
0.31% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-CHAINGUARDLATEST-VLLMOPENAICUDA130-21175638
  • published17 Oct 2026
  • disclosed5 Oct 2026

Introduced: 5 Oct 2026

NewCVE-2026-105757  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-248  (opens in a new tab)
CWE-755  (opens in a new tab)

How to fix?

Upgrade Chainguard vllm-openai-cuda-13.0 to version 0.31.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vllm-openai-cuda-13.0 package and not the vllm-openai-cuda-13.0 package as distributed by Chainguard. See How to fix? for Chainguard relevant fixed versions and status.

vLLM is an inference and serving engine for large language models. Prior to 0.30.0, structured-output request failures can escape request-scoped validation and reach the EngineCore fatal-error path. A per-request backend mismatch can re-raise a grammar compilation exception, padding produced by the ngram_gpu speculative-decoding mode can pass a negative token to guidance validation, and the Rust frontend can admit empty structured-output values that the Python frontend rejects, allowing ordinary constrained-generation requests to terminate the shared engine. This issue is fixed in version 0.30.0.