Use of Insufficiently Random Values Affecting glibc package, versions *


low
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DEBIAN10-GLIBC-453375

  • published

    24 Jul 2019

  • disclosed

    15 Jul 2019

How to fix?

There is no fixed version for Debian:10 glibc.

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

** DISPUTED ** GNU Libc current is affected by: Mitigation bypass. The impact is: Attacker may guess the heap addresses of pthread_created thread. The component is: glibc. NOTE: the vendor's position is "ASLR bypass itself is not a vulnerability."