Use After Free Affecting iproute2 package, versions *


low
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DEBIAN10-IPROUTE2-568742

  • published

    10 May 2020

  • disclosed

    9 May 2020

How to fix?

There is no fixed version for Debian:10 iproute2.

NVD Description

Note: Versions mentioned in the description apply to the upstream iproute2 package.

iproute2 before 5.1.0 has a use-after-free in get_netnsid_from_name in ip/ipnetns.c. NOTE: security relevance may be limited to certain uses of setuid that, although not a default, are sometimes a configuration option offered to end users. Even when setuid is used, other factors (such as C library configuration) may block exploitability.