Information Exposure Affecting libgcrypt20 package, versions *


low

Snyk CVSS

    Attack Complexity High
    User Interaction Required
    Confidentiality High
    Integrity High
Expand this section
NVD
6.3 medium
Expand this section
SUSE
5.5 medium
Expand this section
RHEL
6.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-LIBGCRYPT20-460489
  • published 29 Aug 2019
  • disclosed 25 Sep 2019

How to fix?

There is no fixed version for Debian:10 libgcrypt20.

NVD Description

Note: Versions mentioned in the description apply to the upstream libgcrypt20 package.

It was discovered that there was a ECDSA timing attack in the libgcrypt20 cryptographic library. Version affected: 1.8.4-5, 1.7.6-2+deb9u3, and 1.6.3-2+deb8u4. Versions fixed: 1.8.5-2 and 1.6.3-2+deb8u7.