Use After Free Affecting liblouis package, versions <3.3.0-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.76% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-LIBLOUIS-343589
  • published29 Aug 2017
  • disclosed29 Aug 2017

Introduced: 29 Aug 2017

CVE-2017-13741  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:10 liblouis to version 3.3.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis package and not the liblouis package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

There is a use-after-free in the function compileBrailleIndicator() in compileTranslationTable.c in Liblouis 3.2.0 that will lead to a remote denial of service attack.