Out-of-bounds Write Affecting libpng1.6 package, versions *


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
Red Hat
7 high
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-LIBPNG16-296471
  • published 16 Aug 2018
  • disclosed 10 Jul 2019

How to fix?

There is no fixed version for Debian:10 libpng1.6.

NVD Description

Note: Versions mentioned in the description apply to the upstream libpng1.6 package.

An issue has been found in third-party PNM decoding associated with libpng 1.6.35. It is a stack-based buffer overflow in the function get_token in pnm2png.c in pnm2png.