CVE-2019-9893 Affecting libseccomp package, versions *


low

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
Red Hat
7.3 high
Expand this section
SUSE
5.1 medium
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-LIBSECCOMP-341044
  • published 21 Mar 2019
  • disclosed 21 Mar 2019

How to fix?

There is no fixed version for Debian:10 libseccomp.

NVD Description

Note: Versions mentioned in the description apply to the upstream libseccomp package.

libseccomp before 2.4.0 did not correctly generate 64-bit syscall argument comparisons using the arithmetic operators (LT, GT, LE, GE), which might able to lead to bypassing seccomp filters and potential privilege escalations.