Memory Leak The advisory has been revoked - it doesn't affect any version of package lighttpd  (opens in a new tab)


Threat Intelligence

EPSS
3.83% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-LIGHTTPD-3033938
  • published27 Sept 2022
  • disclosed6 Oct 2022

Introduced: 27 Sep 2022

CVE-2022-41556  (opens in a new tab)
CWE-401  (opens in a new tab)

Amendment

The Debian security team deemed this advisory irrelevant for Debian:10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lighttpd package and not the lighttpd package as distributed by Debian.

A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.