CVE-2010-3900 Affecting midori package, versions <0.2.7-1.1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.24% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-MIDORI-266944
  • published14 Oct 2010
  • disclosed14 Oct 2010

Introduced: 14 Oct 2010

CVE-2010-3900  (opens in a new tab)

How to fix?

Upgrade Debian:10 midori to version 0.2.7-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream midori package and not the midori package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

Midori before 0.2.5, when WebKitGTK+ before 1.1.14 or LibSoup before 2.29.91 is used, does not verify X.509 certificates, which allows man-in-the-middle attackers to spoof arbitrary https web sites via a crafted server certificate, a related issue to CVE-2010-3312.

CVSS Base Scores

version 3.1