Cross-site Scripting (XSS) Affecting node-serve-index package, versions <1.9.1-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
2.48% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-NODESERVEINDEX-271168
  • published23 Jan 2017
  • disclosed23 Jan 2017

Introduced: 23 Jan 2017

CVE-2015-8856  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:10 node-serve-index to version 1.9.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-serve-index package and not the node-serve-index package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.

CVSS Base Scores

version 3.1