Out-of-Bounds Affecting pcre3 package, versions <7.6-1


medium

Snyk CVSS

    Attack Complexity Low
NVD  high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-PCRE3-345522
  • published 18 Feb 2008
  • disclosed 18 Feb 2008

How to fix?

Upgrade Debian:10 pcre3 to version 7.6-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcre3 package and not the pcre3 package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

Buffer overflow in PCRE before 7.6 allows remote attackers to execute arbitrary code via a regular expression containing a character class with a large number of characters with Unicode code points greater than 255.