CVE-2019-16056 Affecting python2.7 package, versions <2.7.16-2+deb10u1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
7.5 high
Expand this section
SUSE
6.5 medium
Expand this section
RHEL
7.3 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-PYTHON27-461185
  • published 9 Sep 2019
  • disclosed 6 Sep 2019

How to fix?

Upgrade Debian:10 python2.7 to version 2.7.16-2+deb10u1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream python2.7 package. See How to fix? for Debian:10 relevant versions.

An issue was discovered in Python through 2.7.16, 3.x through 3.5.7, 3.6.x through 3.6.9, and 3.7.x through 3.7.4. The email module wrongly parses email addresses that contain multiple @ characters. An application that uses the email module and implements some kind of checks on the From/To headers of a message could be tricked into accepting an email address that should be denied. An attack may be the same as in CVE-2019-11340; however, this CVE applies to Python more generally.