Integer Overflow or Wraparound Affecting python-cryptography package, versions *


low

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Availability High

    Threat Intelligence

    EPSS 0.85% (82nd percentile)
Expand this section
NVD
9.1 critical
Expand this section
SUSE
7.5 high
Expand this section
Red Hat
8.2 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-PYTHONCRYPTOGRAPHY-1070576
  • published 8 Feb 2021
  • disclosed 7 Feb 2021

How to fix?

There is no fixed version for Debian:10 python-cryptography.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-cryptography package and not the python-cryptography package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

In the cryptography package before 3.3.2 for Python, certain sequences of update calls to symmetrically encrypt multi-GB values could result in an integer overflow and buffer overflow, as demonstrated by the Fernet class.