CVE-2024-26130 Affecting python-cryptography package, versions *


low

Snyk CVSS

      Threat Intelligence

      EPSS 0.05% (15th percentile)
    Expand this section
    Red Hat
    7.5 high
    Expand this section
    SUSE
    6.2 medium

    Do your applications use this vulnerable package?

    In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

    Test your applications
    • Snyk ID SNYK-DEBIAN10-PYTHONCRYPTOGRAPHY-6261576
    • published 22 Feb 2024
    • disclosed 21 Feb 2024

    How to fix?

    There is no fixed version for Debian:10 python-cryptography.

    NVD Description

    Note: Versions mentioned in the description apply only to the upstream python-cryptography package and not the python-cryptography package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

    cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Starting in version 38.0.0 and prior to version 42.0.4, if pkcs12.serialize_key_and_certificates is called with both a certificate whose public key did not match the provided private key and an encryption_algorithm with hmac_hash set (via PrivateFormat.PKCS12.encryption_builder().hmac_hash(...), then a NULL pointer dereference would occur, crashing the Python process. This has been resolved in version 42.0.4, the first version in which a ValueError is properly raised.