Out-of-Bounds Affecting rustc package, versions <1.2.0+dfsg1-1


Severity

Recommended
low

Based on Debian security rating.

Threat Intelligence

EPSS
1.32% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN10-RUSTC-1244877
  • published12 Apr 2021
  • disclosed11 Apr 2021

Introduced: 11 Apr 2021

CVE-2015-20001  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:10 rustc to version 1.2.0+dfsg1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rustc package and not the rustc package as distributed by Debian. See How to fix? for Debian:10 relevant fixed versions and status.

In the standard library in Rust before 1.2.0, BinaryHeap is not panic-safe. The binary heap is left in an inconsistent state when the comparison of generic elements inside sift_up or sift_down_range panics. This bug leads to a drop of zeroed memory as an arbitrary type, which can result in a memory safety violation.

CVSS Base Scores

version 3.1