Improper Input Validation Affecting shadow package, versions <1:4.1.5-1


low

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.8 high
Red Hat  high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-SHADOW-306188
  • published 27 Jun 2018
  • disclosed 4 Nov 2019

How to fix?

Upgrade Debian:10 shadow to version 1:4.1.5-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shadow package and not the shadow package as distributed by Debian:10. See How to fix? for Debian:10 relevant fixed versions and status.

There is a possible tty hijacking in shadow 4.x before 4.1.5 and sudo 1.x before 1.7.4 via "su - user -c program". The user session can be escaped to the parent session by using the TIOCSTI ioctl to push characters into the input buffer to be read by the next process.