Out-of-bounds Read Affecting tar package, versions *


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
Red Hat
3.3 low
Expand this section
SUSE
3.3 low
Expand this section
NVD
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN10-TAR-1063001
  • published 20 Jan 2021
  • disclosed 26 Mar 2021

How to fix?

There is no fixed version for Debian:10 tar.

NVD Description

Note: Versions mentioned in the description apply to the upstream tar package.

A flaw was found in the src/list.c of tar 1.33 and earlier. This flaw allows an attacker who can submit a crafted input file to tar to cause uncontrolled consumption of memory. The highest threat from this vulnerability is to system availability.